12 апреля 2023
В закладки
Обсудить
Жалоба
16+
Итоговый тест по информатике в 10 классе
Базовый уровень.
test-i10.docx
test-i10.pdf
1. В кодировке КОИ-8 каждый символ кодируется 8 битами. Определите информационный объем (в байтах) сообщения в данной кодировке.
Длина данного текста 32 символа.
2. Что можно сказать о таблице символов ASCII?
а) в ней первоначально кодировалось 128 символов
б) к ней относятся символы с кодами от 128 до 255
в) кодировка ASCII содержит арабские цифры
г) расширенные символы имеют коды 0-128
д) ASCII — American Standard Code for Information Interchange
3. Информационный объем сообщения, записанного в 16-битовом коде Unicode составляет 12 Кбайт. Сколько страниц занимает сообщение, если известно, что на каждой странице 64 строки по 32 сим-вола в строке?
4. Графический файл содержит черно-белое изображение с 16 градациями серого цвета размером 10х10 пикселей. Каков информационный объем (в байтах) этого файла?
5. Выполните сложение в двоичной системе счисления:
101010 + 1110
Результат запишите в двоичной системе счисления.
6. Выберите правильное окончание определения: «Часть памяти компьютера, в которой хранятся исполняемые в данный момент программы и оперативно необходимые для этого данные, называется...».
а) постоянная память
б) оперативная память
в) внешняя память
г) дисковая память
д) полупостоянная память
7. Выберите правильное окончание определения: «Для долговременного хранения программ и данных предназначена ...»
а) постоянная память
б) оперативная память
в) внешняя память
г) дисковая память
д) полупостоянная память
8. Отметьте все устройства ввода.
а) монитор
б) клавиатура
в) сканер
г) принтер
д) флэш-диск
9. Отметьте все устройства вывода среди перечисленных.
а) монитор
б) клавиатура
в) сканер
г) принтер
д) флэш-диск
10. Отметьте все правильные утверждения о принципе открытой архитектуры.
а) компьютер собирается из отдельных частей как конструктор
б) способы соединения этих частей и обмена информацией доступны всем желающим
в) любые новые устройства можно подключить к компьютеру
г) для каждого нового устройства нужно установить драйвер
д) каждый новый блок должен быть совместим со старым и легко устанавливаться в том же месте компьютера
11. Чему будет равна переменная «c» после выполнения этой программы:
a = 36 ;
b = 2 ;
b = a / b + b;
c = a * b + a;
12. Определите значение переменной «a» после выполнения фрагмента программы:
a = 20;
b = 4 ;
if a < 0 and a>b then a := 7;
if a > 0 and a > b then a := 8;
13. Чему будет равно значение переменной «s» после выполнения этого цикла?
s:=0;
i:=0;
while i<5 do
begin
i:=i+1;
s:=s+1;
end;
14. Чему будет равно значение переменной «s» после выполнения этого цикла?
s:=0;
for i:=0 to 5 do s:=s+i;
15. Сформированный массив имеет вид: {1;2;3;4;5;6;7}. Укажите верную запись цикла для заполнения массива
а) for i:=1 to 7 write (a[i]);
б) for i:=1 to 7 a[i]:=7;
в) for i:=1 to 7 a[i]:=i;
г) for i:=1 to 7 a[i]:=i*i;
д) for i:=1 to 7 a[i]:=2*i-1;
Ответы
1. 32 байта
2. авд
3. 3 страницы (I=K*i, 12*1024*8=(х*64*32)*16, х=3)
4. 50 байт (I = 10x10 * 4=400 бит = 50 байт)
5. 111000
6. б
7. в
8. бв
9. аг
10. абд
11. 756
12. 8
13. 10
14. 15
15. в
test-i10.docx
test-i10.pdf
1. В кодировке КОИ-8 каждый символ кодируется 8 битами. Определите информационный объем (в байтах) сообщения в данной кодировке.
Длина данного текста 32 символа.
2. Что можно сказать о таблице символов ASCII?
а) в ней первоначально кодировалось 128 символов
б) к ней относятся символы с кодами от 128 до 255
в) кодировка ASCII содержит арабские цифры
г) расширенные символы имеют коды 0-128
д) ASCII — American Standard Code for Information Interchange
3. Информационный объем сообщения, записанного в 16-битовом коде Unicode составляет 12 Кбайт. Сколько страниц занимает сообщение, если известно, что на каждой странице 64 строки по 32 сим-вола в строке?
4. Графический файл содержит черно-белое изображение с 16 градациями серого цвета размером 10х10 пикселей. Каков информационный объем (в байтах) этого файла?
5. Выполните сложение в двоичной системе счисления:
101010 + 1110
Результат запишите в двоичной системе счисления.
6. Выберите правильное окончание определения: «Часть памяти компьютера, в которой хранятся исполняемые в данный момент программы и оперативно необходимые для этого данные, называется...».
а) постоянная память
б) оперативная память
в) внешняя память
г) дисковая память
д) полупостоянная память
7. Выберите правильное окончание определения: «Для долговременного хранения программ и данных предназначена ...»
а) постоянная память
б) оперативная память
в) внешняя память
г) дисковая память
д) полупостоянная память
8. Отметьте все устройства ввода.
а) монитор
б) клавиатура
в) сканер
г) принтер
д) флэш-диск
9. Отметьте все устройства вывода среди перечисленных.
а) монитор
б) клавиатура
в) сканер
г) принтер
д) флэш-диск
10. Отметьте все правильные утверждения о принципе открытой архитектуры.
а) компьютер собирается из отдельных частей как конструктор
б) способы соединения этих частей и обмена информацией доступны всем желающим
в) любые новые устройства можно подключить к компьютеру
г) для каждого нового устройства нужно установить драйвер
д) каждый новый блок должен быть совместим со старым и легко устанавливаться в том же месте компьютера
11. Чему будет равна переменная «c» после выполнения этой программы:
a = 36 ;
b = 2 ;
b = a / b + b;
c = a * b + a;
12. Определите значение переменной «a» после выполнения фрагмента программы:
a = 20;
b = 4 ;
if a < 0 and a>b then a := 7;
if a > 0 and a > b then a := 8;
13. Чему будет равно значение переменной «s» после выполнения этого цикла?
s:=0;
i:=0;
while i<5 do
begin
i:=i+1;
s:=s+1;
end;
14. Чему будет равно значение переменной «s» после выполнения этого цикла?
s:=0;
for i:=0 to 5 do s:=s+i;
15. Сформированный массив имеет вид: {1;2;3;4;5;6;7}. Укажите верную запись цикла для заполнения массива
а) for i:=1 to 7 write (a[i]);
б) for i:=1 to 7 a[i]:=7;
в) for i:=1 to 7 a[i]:=i;
г) for i:=1 to 7 a[i]:=i*i;
д) for i:=1 to 7 a[i]:=2*i-1;
Ответы
1. 32 байта
2. авд
3. 3 страницы (I=K*i, 12*1024*8=(х*64*32)*16, х=3)
4. 50 байт (I = 10x10 * 4=400 бит = 50 байт)
5. 111000
6. б
7. в
8. бв
9. аг
10. абд
11. 756
12. 8
13. 10
14. 15
15. в